Функция MS Excel ИНДЕКС (INDEX)

Функция ИНДЕКС применяется, когда из имеющейся таблицы нужно извлечь содержимое определенной ячейки, местоположение которой известно.

Допустим, у нас есть таблица и нужно получить значение ячейки, находящейся на пересечении 5-й строки и 2-го столбца, как на рисунке.

Функция ИНДЕКС

Воспользуемся функцией ИНДЕКС, которая имеет следующий синтаксис.

ИНДЕКС(ссылка; номер_строки; [номер_столбца]; [номер_области])

Ссылка – диапазон, внутри которого находится искомая ячейка.

Номер_строки – номер строки диапазона, в которой находится искомая ячейка.

Номер_столбца – номер столбца диапазона, в которой находится искомая ячейка.

Номер_области – необязательный аргумент. Используется в том случае, когда указываются несколько несмежных диапазонов. Обычно никто эту настройку не использует.

Итак, для того, чтобы получить значение из 5-й строки и 2-го столбца указанной таблицы, следует записать функцию ИНДЕКС следующим образом:

=ИНДЕКС(B2:E9;5;2)

Результатом будет число 30. Аналогично можно извлечь значение любой ячейки в рамках указанного диапазона.

Функция ИНДЕКС используется тогда, когда известно расположение ячейки внутри некоторого массива и нужно отобразить ее содержимое. Очень часто ИНДЕКС используется, как составная часть мегаформулы.

Поделиться в социальных сетях:
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •